iPhone 4 にも対応したキャリアアンロックツール Ultrasn0w 1.0-1 がリリースされました。対応するデバイス / ベースバンド(モデムファームウェア) バージョンは iPhone 4 が 01.59.00 つまり最新、3G / 3GS では04.26.08、 05.11.07、05.12.01、05.13.04。iPhone 4の場合は JailbreakMe で脱獄してからCydiaでultrasn0wをインストールする流れです。検索しても出ない場合はリンク先のDev-Team Blogを参照。Jailbreak / 脱獄と(キャリア)アンロックの差があやふやだったりするかたは特に気にする必要もありません。